18 July, 2011

CCNA Skills Integration Challenge PT Activity 8.6.1 - Task 5

Task 5: Configure Inter-VLAN Routing
Step 1. Configure each Branch router for inter-VLAN routing.
Using the addressing table for Branch routers, configure and activate the LAN interface for inter-VLAN routing. VLAN 99 is the native VLAN.
Step 2. Verify routing tables.
Each Branch router should now have six directly connected networks and one static default route

Prepare Branch routers:




B1(config)#in fastEthernet 0/0.10<br />
B1(config-subif)#encapsulation dot1Q 10<br />
B1(config-subif)#ip add 10.1.10.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
B1(config)#in fastEthernet 0/0.20<br />
B1(config-subif)#encapsulation dot1Q 20<br />
B1(config-subif)#ip add 10.1.20.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
B1(config)#in fastEthernet 0/0.30<br />
B1(config-subif)#encapsulation dot1Q 30<br />
B1(config-subif)#ip add 10.1.30.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
B1(config)#in fastEthernet 0/0.88<br />
B1(config-subif)#encapsulation dot1Q 88<br />
B1(config-subif)#ip add 10.1.88.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config)#in fastEthernet 0/0.99<br />
B1(config-subif)#encapsulation dot1Q 99 native<br />
B1(config-subif)#ip add 10.1.99.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
%LINK-5-CHANGED: Interface Vlan99, changed state to up<br />
B1(config)#in fastEthernet 0/0.10
B1(config-subif)#encapsulation dot1Q 10
B1(config-subif)#ip add 10.1.10.1 255.255.255.0
B1(config-subif)#no sh
B1(config-subif)#exit
B1(config)#in fastEthernet 0/0.20
B1(config-subif)#encapsulation dot1Q 20
B1(config-subif)#ip add 10.1.20.1 255.255.255.0
B1(config-subif)#no sh
B1(config-subif)#exi
B1(config)#in fastEthernet 0/0.30
B1(config-subif)#encapsulation dot1Q 30
B1(config-subif)#ip add 10.1.30.1 255.255.255.0
B1(config-subif)#no sh
B1(config-subif)#exi
B1(config)#in fastEthernet 0/0.88
B1(config-subif)#encapsulation dot1Q 88
B1(config-subif)#ip add 10.1.88.1 255.255.255.0
B1(config-subif)#no sh
B1(config)#in fastEthernet 0/0.99
B1(config-subif)#encapsulation dot1Q 99 native
B1(config-subif)#ip add 10.1.99.1 255.255.255.0
B1(config-subif)#no sh
B1(config-subif)#exi
%LINK-5-CHANGED: Interface Vlan99, changed state to up
B1(config)#in fastEthernet 0/0.10<br />
B1(config-subif)#encapsulation dot1Q 10<br />
B1(config-subif)#ip add 10.1.10.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
B1(config)#in fastEthernet 0/0.20<br />
B1(config-subif)#encapsulation dot1Q 20<br />
B1(config-subif)#ip add 10.1.20.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
B1(config)#in fastEthernet 0/0.30<br />
B1(config-subif)#encapsulation dot1Q 30<br />
B1(config-subif)#ip add 10.1.30.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
B1(config)#in fastEthernet 0/0.88<br />
B1(config-subif)#encapsulation dot1Q 88<br />
B1(config-subif)#ip add 10.1.88.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config)#in fastEthernet 0/0.99<br />
B1(config-subif)#encapsulation dot1Q 99 native<br />
B1(config-subif)#ip add 10.1.99.1 255.255.255.0<br />
B1(config-subif)#no sh<br />
B1(config-subif)#exi<br />
%LINK-5-CHANGED: Interface Vlan99, changed state to up<br />

Go to the switch B1-S1 and inter vlan-routing commands:

B1-S1(config)#vlan 10<br />
B1-S1(config-vlan)#name Admin<br />
B1-S1(config)#vlan 20<br />
B1-S1(config-vlan)#name Sales<br />
B1-S1(config-vlan)#exi<br />
B1-S1(config)#vlan 30<br />
B1-S1(config-vlan)#name Production<br />
B1-S1(config-vlan)#vlan 88<br />
B1-S1(config-vlan)#name Wireless<br />
B1-S1(config-vlan)#exi<br />
B1-S1(config)#vlan 99<br />
B1-S1(config-vlan)#name Mgmt&amp;Native<br />
B1-S1(config-vlan)#exi<br />
Switch(config)#host B1-S1<br />
B1-S1(config)#interface vlan 99<br />
B1-S1(config-if)#ip add 10.1.99.21 255.255.255.0<br />
B1-S1(config-if)#exit<br />
B1-S1(config-if)#in fa 0/1<br />
B1-S1(config-if)#switchport trunk native vl 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/2<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/3<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/4<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/5<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi
 B1-S1(config)#vlan 10
B1-S1(config-vlan)#name Admin
B1-S1(config)#vlan 20
B1-S1(config-vlan)#name Sales
B1-S1(config-vlan)#exi
B1-S1(config)#vlan 30
B1-S1(config-vlan)#name Production
B1-S1(config-vlan)#name Wireless
B1-S1(config-vlan)#exi
B1-S1(config)#vlan 99
B1-S1(config-vlan)#name Mgmt&amp;Native
B1-S1(config-vlan)#exi
Switch(config)#host B1-S1
B1-S1(config)#interface vlan 99
B1-S1(config-if)#ip add 10.1.99.21 255.255.255.0
B1-S1(config-if)#exit
B1-S1(config-if)#in fa 0/1
B1-S1(config-if)#switchport trunk native vl 99
B1-S1(config-if)#switchport mode dynamic auto
B1-S1(config-if)#switchport mode trunk
B1-S1(config)#exi
B1-S1(config)#interface fastEthernet 0/2
B1-S1(config-if)#switchport native vlan 99
B1-S1(config-if)#switchport mode dynamic auto
B1-S1(config-if)#switchport mode trunk
B1-S1(config)#exi
B1-S1(config)#interface fastEthernet 0/3
B1-S1(config-if)#switchport native vlan 99
B1-S1(config-if)#switchport mode dynamic auto
B1-S1(config-if)#switchport mode trunk
B1-S1(config)#exi
B1-S1(config)#interface fastEthernet 0/4
B1-S1(config-if)#switchport native vlan 99
B1-S1(config-if)#switchport mode dynamic auto
B1-S1(config-if)#switchport mode trunk
B1-S1(config)#exi
B1-S1(config)#interface fastEthernet 0/5
B1-S1(config-if)#switchport native vlan 99
B1-S1(config-if)#switchport mode dynamic auto
B1-S1(config-if)#switchport mode trunk
B1-S1(config)#exi
B1-S1(config)#vlan 10<br />
B1-S1(config-vlan)#name Admin<br />
B1-S1(config)#vlan 20<br />
B1-S1(config-vlan)#name Sales<br />
B1-S1(config-vlan)#exi<br />
B1-S1(config)#vlan 30<br />
B1-S1(config-vlan)#name Production<br />
B1-S1(config-vlan)#vlan 88<br />
B1-S1(config-vlan)#name Wireless<br />
B1-S1(config-vlan)#exi<br />
B1-S1(config)#vlan 99<br />
B1-S1(config-vlan)#name Mgmt&amp;Native<br />
B1-S1(config-vlan)#exi<br />
Switch(config)#host B1-S1<br />
B1-S1(config)#interface vlan 99<br />
B1-S1(config-if)#ip add 10.1.99.21 255.255.255.0<br />
B1-S1(config-if)#exit<br />
B1-S1(config-if)#in fa 0/1<br />
B1-S1(config-if)#switchport trunk native vl 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/2<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/3<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/4<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi<br />
B1-S1(config)#interface fastEthernet 0/5<br />
B1-S1(config-if)#switchport native vlan 99<br />
B1-S1(config-if)#switchport mode dynamic auto<br />
B1-S1(config-if)#switchport mode trunk<br />
B1-S1(config)#exi

And set the default gateway for all Branch switch:
B1-S1(config)#ip default-gateway 10.1.99.1

Finally step is check the ip routing table on the B1:

B1#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is 10.255.255.1 to network 0.0.0.0     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masksC       10.1.10.0/24 is directly connected, FastEthernet0/0.10
C       10.1.20.0/24 is directly connected, FastEthernet0/0.20
C       10.1.30.0/24 is directly connected, FastEthernet0/0.30
C       10.1.88.0/24 is directly connected, FastEthernet0/0.88
C       10.1.99.0/24 is directly connected, FastEthernet0/0.99
C       10.255.255.0/30 is directly connected, Serial0/0/0
S*   0.0.0.0/0 [1/0] via 10.255.255.1

Same configuration apply for other switch => B1-S2 and B1-S3 and routers=> B2 (switch B2-S1, B2-S2, B2-S3), B3 (B3-S1, B3-S2, B3-S3), but with appropriate ip address.

No comments:

Post a Comment